Custom domain not showing

Hi,
I’m trying to setup a custom domain for my app, it runs correctly under the qovery.io address.

I read the doc and set up my qovery.yml file like so:


application:
  name: "strapi"
  project: "mysecretname"
  publicly_accessible: true
  cpu: "800m"
  ram: "512mb"
  port: 1337
  start_timeout: "480s"
  storage:
  - name: "data"
    size: "5GB"
    type: "ssd"
    mount_point: "/srv/app"
databases:
- type: "MYSQL"
  name: "my-sql"
  version: "8"
routers:
- name: "main"
  custom_domains:
  - branch: "master"
    domain: "admin.mysecretdomain.fr"
  routes:
  - application_name: "strapi"
    paths:
    - "/*"

Though my domain doesn’t show up in the Custom Domains list on the web interface, nor in qovery domain list cli command.

Am I missing something?

Thanks!

Hello,
did you enable end-to-end SSL/TLS encryption in your DNS provider setup ? We have an example with Cloudflare here.

I didn’t set up my DNS yet as I am stuck at the first step, I can’t get the validation domain from the domain list to add the CNAME record.

Ok I finally figured it out. I set up the branch to “master” instead of “main” in my qovery.yml file.

What lead me to this error is that the Strapi template uses the “main” branch, but the “Custom domain” doc uses the “master” branch. Maybe unifying the branch accross the sources could be helpful?

1 Like

It’s gonna be hard since all git repositories use their own branch naming convention. Github switch from “master” to “main” for marketing/political reason few months ago. In Gitlab it’s still master and if I remember well it’s also “master” for Bitbucket.