"Select a repo" don't list the repositorie I want to use

Issues information

Your issue

Describe here your issue

I created a project and want to use an already existing application, so I follow the step and end up on the “Add an application” page, I click on “Connect to Github” then a select “Select a repo” appear with a list of repositories. :partying_face: But I can’t find the project I want to use from this list. :sob:

I check on Github in my organization settings where I have the application I want to use and confirmed that in the “Third-party access” Qovery is listed and approved!

I waited more than 24 hours, I thought there’s some cache or connection problem… I check again today and still don’t have the project listed. What did I mess? Is there a limitation on the number of organizations, now only 2 are listed, my personal account with all my forks and another Organization that was already approved when I registered to Qovery.

Thanks!

Hello,

First of all, is the repo you want to use in Qovery yours ?

If no, it will be impossible for Qovery to use since the creator of the repo doesn’t allow the third party acces.

If yes, could you let us now and give as many info on it as you can (public, private, etc…) ?

1 Like

Hi, and thanks for the reply.

Actually the data fetched are not correct they list the repository in the wrong organization… so maybe a bug when fetching or in the Github result.

Basically the project name is diagrams-web and is in the diagrams-web organization as written in the first post. But the list display it in another organization.
Maybe an edge case, anyway I can continue.

Thanks for the reply!

I was not able to continue it’s somehow strange.

Here the screenshot of the console page:

I was not able to take a screenshot of the select so I took with the inspect and as you can see the repository diagrams-web is listed 2 times under my personal user (line 1 and 13).
I expect that the first line organization is not correct, but If I continue Qovery said that he will create a repository in my personal repository which is not what I want as I want to work with the repository of the organization.
Also on line 2 the ARTv2 repository in not my repository but one from another organization I am in (I didn’t fork it).
The repositories fetch is completely wired!

Yes it’s mine.

and yes qovery have access.

Hi @gab, thank you for reporting this bug. I confirm that it is a bug in our API. Our backend team will fix it with the next version of our API that is planned in beta for June 2021 and released for September 2021. Thank you Gab for reporting it.

1 Like

@rophilogene
Do you want me to open an issue, so I can follow and test again after it release.

Thanks again for the fast reply!

We have open a bug request on our side but we can keep track here as well. Yes do open an issue :slight_smile: Thank you Gab

Opened an issue here: