Strapi SSL connection error

Issues information

Your issue

Describe here your issue

When I deploy my strapi app I keep getting this error: Error: The server does not support SSL connections. I had the same issue on Heroku hosting so I put the same config but it doesn’t work…

Dockerfile content (if any)

WORKDIR /app
COPY . . 
RUN yarn
RUN yarn run build
EXPOSE 1337
CMD ["strapi", "start"]

Hello,
it looks like it’s an issue with strapi production and postgres:
Database SSL Config not working in Production mode · Issue #4467 · strapi/strapi · GitHub .

I’ll do some check but I guess you have to change the database type used. Mysql should work.
If you want to replace the db, edit the qovery.yaml file and delete the database part. Then push to update it on Qovery. When it’s done, edit the file again, add a mysql database and push again.

I just fix this by disabling the ssl option:

  defaultConnection: "default",
  connections: {
    default: {
      connector: "bookshelf",
      settings: {
        client: "postgres",
        host: env("DATABASE_HOST", "localhost"),
        port: env.int("DATABASE_PORT", 5432),
        database: env("DATABASE_NAME", "strapi"),
        username: env("DATABASE_USERNAME", "strapi"),
        password: env("DATABASE_PASSWORD", "strapi"),
        ssl: false,
      },
    },
  },
});